Also use check in add_new_check.py for terminology consistency.
My GitHub ID is EugeneZelenko, if it's necessary for attribution.
I think it'll be easier to test script locally, since several (at least two) child revisions would be necessary. By the word, main script boy is borrowed from add_new_check.py, so difference only in section name and regular expression for entry.
So I tried to ran ./rename_check.py readability-braces-around-statements readability-braces and results were less than desirable. It renamed the readability-braces-around-statements but it also renamed the google alias to google-readability-braces. In the documentation for google-readability-braces it changed the subject line to
Feel like the correct course of action is to match against the entire check name rather than a sub string of it (which i guess was unintentional). This doesn't need to be done in this review and could (should) be a follow up.
The actual alphabetical ordering of the release notes works as intended though.
What's the preferred variable naming convention in Python in LLVM? Looking at the two scripts now, I see that the naming style is already quite inconsistent. It would be nice to make naming consistent in these scripts.
Not an action item for this patch, just a drive-by comment.
Another side effect is that rename_check.py messes list.rst by removing "Offer fixes". Probably proper solution would be moving update_checks_list from add_new_check.py to shared module.