Add omp_pause_resource and omp_pause_resource_all API and enum, plus stub for internal implementation. Implemented callable helper function to do local pause, and added basic functionality for hard and soft pause.
Details
Diff Detail
- Repository
- rOMP OpenMP
Event Timeline
runtime/src/include/50/omp_lib.f.var | ||
---|---|---|
292 | Parameters should be re-named as (kind, device_num). Because in Fortran user can provide named arguments, so we should use same names as in the specification. | |
299 | Parameter "level" should be renamed to "kind" to correspond to the specification. | |
runtime/src/include/50/omp_lib.f90.var | ||
308 | Parameters should be re-named as (kind, device_num). Because in Fortran user can provide named arguments, so we should use same names as in the specification. | |
315 | Parameter "level" should be renamed to "kind" to correspond to the specification. | |
runtime/src/include/50/omp_lib.h.var | ||
340 | Parameters should be re-named as (kind, device_num). Because in Fortran user can provide named arguments, so we should use same names as in the specification. | |
347 | Parameter "level" should be renamed to "kind" to correspond to the specification. |
This commit causes Flang unit tests to fail.
openmp/trunk/runtime/src/include/50/omp_lib.h.var | ||
---|---|---|
143 ↗ | (On Diff #182117) | These three lines are too long causing OpenMP test cases from Flang fortran compiler to fail. See how this problem is addressed in the lines above and below. |
openmp/trunk/runtime/src/include/50/omp_lib.h.var | ||
---|---|---|
44 ↗ | (On Diff #182117) | Sure, fixed this as well. Thanks, Kelvin. |
Parameters should be re-named as (kind, device_num). Because in Fortran user can provide named arguments, so we should use same names as in the specification.