The warning piece traditionally describes the bug itself, i.e., "The bug is a _____": "Attempt to delete released memory", "Resource leak", "Method call on a moved-from object".
The "moved-from" terminology we adopt here still feels a bit weird to me, but i don't have a better suggestion, so i just removed the single-quotes so that to at least feel proud about what we have.
Event pieces produced by the visitor are usually in a present tense, i.e., "At this moment _____": "Memory is released", "File is closed", "Object is moved", etc.
Additionally, type information is added into the event pieces for STL objects (in order to highlight that it is in fact an STL object), and the respective event piece now mentions that the object is left in an unspecified state after it was moved, which is a vital piece of information to understand the bug.
Maybe move this in-class?