Separate LoopTraversal and BreakFalseDeps into their own files.
Moving a couple of comments around to make the new code more readable (i.e. LoopTraversal algorithm is now descirbed in the LoopTraversal header file and not in the traverse() method implementation)
This change is NFC.
This is the forth of 5 patches that fix bugzilla https://bugs.llvm.org/show_bug.cgi?id=33869
Previous patches:
https://reviews.llvm.org/D40330
https://reviews.llvm.org/D40331
https://reviews.llvm.org/D40332
Next patches:
https://reviews.llvm.org/D40334