Introduce acc.update_host and acc.update_device as data
operands operation to be used by the acc.update op.
Details
Details
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
Comment Actions
Looks great to me - glad to see this representation normalized too :)
Just one suggestion - I find the current names ambiguous without the word "update"
mlir/include/mlir/Dialect/OpenACC/OpenACCOps.td | ||
---|---|---|
87–89 | Can we please rename these to: |
mlir/include/mlir/Dialect/OpenACC/OpenACCOps.td | ||
---|---|---|
87–89 | I'll update that. |
Can we please rename these to:
OpenACC_UpdateHostClause : I64EnumAttrCase<"acc_update_host", 17>;
OpenACC_UpdateSelfClause : I64EnumAttrCase<"acc_update_self", 17>;
OpenACC_UpdateDeviceClause : I64EnumAttrCase<"acc_update_device", 17>;