This is an archive of the discontinued LLVM Phabricator instance.

[DebugInfo][NFC] Rename is/setUndef to is/setKilllocation
ClosedPublic

Authored by Orlando on Jan 3 2023, 9:08 AM.

Details

Summary

These names better reflect the semantics and also the implementation, since it's not just "undef" operands that are sentinels used to signal that the debug intrinsic terminates dominating locations definitions.

Related to https://discourse.llvm.org/t/auto-undef-debug-uses-of-a-deleted-value

Diff Detail

Event Timeline

Orlando created this revision.Jan 3 2023, 9:08 AM
Herald added a project: Restricted Project. · View Herald TranscriptJan 3 2023, 9:08 AM
Herald added a subscriber: hiraditya. · View Herald Transcript
Orlando requested review of this revision.Jan 3 2023, 9:08 AM
Herald added a project: Restricted Project. · View Herald TranscriptJan 3 2023, 9:08 AM
StephenTozer accepted this revision.Jan 4 2023, 8:30 AM

LGTM with the suggested "changes".

llvm/lib/CodeGen/AssignmentTrackingAnalysis.cpp
2114

I think the removal of DVI->getValue() == nullptr should be in the previous patch - would call it a nit, but probably important to preserve the obvious trivial-ness of this patch.

llvm/lib/Transforms/Scalar/LoopStrengthReduce.cpp
6549–6551

Also should be moved into the previous patch.

This revision is now accepted and ready to land.Jan 4 2023, 8:30 AM
Orlando marked 2 inline comments as done.Jan 6 2023, 1:13 AM

Thanks for the review(s).

llvm/lib/CodeGen/AssignmentTrackingAnalysis.cpp
2114

SGTM, that also lets me re-jig the patch dependencies a bit.

This revision was landed with ongoing or failed builds.Jan 6 2023, 1:16 AM
This revision was automatically updated to reflect the committed changes.
Orlando marked an inline comment as done.