Page MenuHomePhabricator

[NFC][AAPointerInfo] rename OffsetAndSize to RangeTy
ClosedPublic

Authored by sameerds on Nov 24 2022, 2:36 AM.

Details

Summary

This is in preparation for future changes that introduce an actual list of
ranges per Access, to be called a RangeList.

Diff Detail

Event Timeline

sameerds created this revision.Nov 24 2022, 2:36 AM
Herald added a project: Restricted Project. · View Herald TranscriptNov 24 2022, 2:36 AM
sameerds requested review of this revision.Nov 24 2022, 2:36 AM
Herald added a reviewer: sstefan1. · View Herald Transcript
Herald added a project: Restricted Project. · View Herald Transcript
jdoerfert accepted this revision.Nov 28 2022, 10:32 AM

Generally LG, but let's wait with merging this until the follow ups are ready. I'm not 100% sure why we call it range in contrast to the explicit offset+size.

This revision is now accepted and ready to land.Nov 28 2022, 10:32 AM
This revision was automatically updated to reflect the committed changes.