The patch may be useful, but I’m concerned with file naming. I think the naming should be consistent. Right now we have vop3, vop3c, vop3cx and now vop3_from…. Maybe we should think over test naming?
IMO vop3_from_vop2_dpp16 is questionable.
To tell you the truth, I considered splitting VOP3 opcodes into native and promoted parts but was unable to find good file names and abandoned the idea.
Any proposals to make the naming consistent?
This test was broken, it was not moved to the intended destination file. Could you double-check that the number of tests (and test lines) is identical before and after the splitting?