Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Unit Tests
Time | Test | |
---|---|---|
2,190 ms | x64 debian > libarcher.races::lock-unrelated.c |
Event Timeline
llvm/lib/CodeGen/GlobalISel/LegalizerHelper.cpp | ||
---|---|---|
4488 | I don't like using Optional for Register, a default constructed Register behaves like none |
llvm/lib/CodeGen/GlobalISel/LegalizerHelper.cpp | ||
---|---|---|
4485 | Might as well hard code the 2 here, treating it as unknown is slightly more confusing | |
4489 | This must be exactly ==, > adds ambiguity | |
llvm/unittests/CodeGen/GlobalISel/LegalizerHelperTest.cpp | ||
898 | Should have a dedicated buildUAddo | |
935 | We should have a dedicated buildUSubo |
llvm/lib/CodeGen/GlobalISel/LegalizerHelper.cpp | ||
---|---|---|
4485 | I think this is supposed to be shared between the overflow ops/non-overflow ops, so it makes sense to not hardcode a 2. I think a comment saying that this should be 1 or 2 would be handy though. |
llvm/unittests/CodeGen/GlobalISel/LegalizerHelperTest.cpp | ||
---|---|---|
898 | I wrote it this way to match the style of the surrounding tests. Which would we prefer here, better style, or more consistency? I'm already changing some other things in favor of better style in the new tests, so I wouldn't be opposed. |
llvm/unittests/CodeGen/GlobalISel/LegalizerHelperTest.cpp | ||
---|---|---|
898 | Raw buildInstr is always uglier and only appropriate if you don't know the exact opcode you're using |
llvm/unittests/CodeGen/GlobalISel/LegalizerHelperTest.cpp | ||
---|---|---|
903–904 | It's a gtest-ism that these should be swapped to get the correct error message as EXPECT_EQ(expected, actual) |
Might as well hard code the 2 here, treating it as unknown is slightly more confusing