Page MenuHomePhabricator

[test] XFAIL two tests with inlining debug info issues on Sparc
ClosedPublic

Authored by ro on Aug 12 2020, 4:33 AM.

Details

Summary

Currently only two test failures remain on Sparc, both sparcv9-sun-solaris2.11 and sparc64-unknown-linux-gnu:

LLVM :: DebugInfo/Generic/debug-label-inline.ll
LLVM :: Linker/subprogram-linkonce-weak.ll

They seem related in that debug info isn't related for inlined functions when LLVM does on other targets.

I've filed separate bugs for both files (Bug 47129 and 47131).

This patch XFAILs the tests.

Tested on sparcv9-sun-solaris2.11 and amd64-pc-solaris2.11.

Diff Detail

Event Timeline

ro created this revision.Aug 12 2020, 4:33 AM
Herald added a project: Restricted Project. · View Herald TranscriptAug 12 2020, 4:33 AM
ro requested review of this revision.Aug 12 2020, 4:33 AM

did this regress recently? Did sparc start using instruction bundles recently? (I've commented on the bugs that it looks like they're both caused to the same bundling of add+ret)

If it was recenty, I'd push back on the bundling change & suggest this needs to be fixed rather than XFAILed. If it's been broken for ages - how? who's working on sparc that they didn't notice the breakage when they committed the bundling changes in the first place?

But I guess if it's been broken for a while, it's reasonable to commit this patch & have followup via bugs.

aprantl accepted this revision.Aug 12 2020, 4:12 PM

LGTM + what @dblaikie said :-)

This revision is now accepted and ready to land.Aug 12 2020, 4:12 PM
ro added a comment.Aug 13 2020, 2:03 AM

did this regress recently? Did sparc start using instruction bundles recently? (I've commented on the bugs that it looks like they're both caused to the same bundling of add+ret)

I've just checked: the debug-label-inline.ll has already been broken when it was introduced in LLVM 8. The subprogram-linkonce-weak.ll test OTOH had worked in LLVM 6 and 8, but started to fail with 9.

AFAICT the Sparc target has been using bundles already in LLVM 3.9; introduced at some point after 3.4.

If it was recenty, I'd push back on the bundling change & suggest this needs to be fixed rather than XFAILed. If it's been broken for ages - how? who's working on sparc that they didn't notice the breakage when they committed the bundling changes in the first place?

Good question about the Sparc port: it seems not to have seen much love recently. My current goal is to get the Solaris/Sparc port to a point where there are no unaccounted failures and the buildbot can be moved back to the regular buildmaster so new failures are noticed quickly.

But I guess if it's been broken for a while, it's reasonable to commit this patch & have followup via bugs.

Good. Thanks for your detective work.

This revision was landed with ongoing or failed builds.Aug 13 2020, 2:13 AM
This revision was automatically updated to reflect the committed changes.