Page MenuHomePhabricator

[mlir][nfc] Rename `promoteMemRefDescriptors` to `promoteOperands`.

Authored by pifon2a on Aug 5 2020, 9:42 AM.



promoteMemRefDescriptors also converts types of every operand, not only
memref-typed ones. I think promoteMemRefDescriptors name does not imply
that and has to be changed to smth better.

Diff Detail

Event Timeline

pifon2a created this revision.Aug 5 2020, 9:42 AM
Herald added a project: Restricted Project. · View Herald TranscriptAug 5 2020, 9:43 AM
pifon2a requested review of this revision.Aug 5 2020, 9:43 AM
pifon2a edited the summary of this revision. (Show Details)Aug 5 2020, 9:44 AM
ftynse accepted this revision.Aug 5 2020, 9:48 AM
This revision is now accepted and ready to land.Aug 5 2020, 9:48 AM