This patch only touched variables and functions in target.
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
Should be easy to address my comments and let us get this merged ASAP.
openmp/libomptarget/src/device.h | ||
---|---|---|
202 | "Function names should be verb phrases (as they represent actions), and command-like function should be imperative. The name should be camel case, and start with a lower case letter (e.g. openFile() or isFoo())." Since we are anyway changing the names. Let us fix them fully. | |
openmp/libomptarget/src/omptarget.cpp | ||
213 | isMemberOf? | |
openmp/libomptarget/src/private.h | ||
29 | Let us kill the pain in one shot. It is just a few more sed. |
"Function names should be verb phrases (as they represent actions), and command-like function should be imperative. The name should be camel case, and start with a lower case letter (e.g. openFile() or isFoo())."
Since we are anyway changing the names. Let us fix them fully.
allocData
deleteData
Please also take this chance to rename
data_retrieve
data_exchange
as well. No good reason to leave these pains.