LGTM, with one nit that I think it is worth addressing before submitting.
While on this, maybe rename the variable VectorType to something that doesn't confuse the types? VecTy?
Wow, yeah, that's a bit of an unfortunate name...
address code review issues
Oh gosh, it's like that everywhere