LC_LOAD_WEAK_DYLIB is analogous to LC_LOAD_DYLIB and doesn't require any special handling.
Test plan: make check-all
Differential D78602
[llvm-objcopy][MachO] Copy LC_LOAD_WEAK_DYLIB load commands alexander-shaposhnikov on Apr 21 2020, 5:26 PM. Authored by
Details LC_LOAD_WEAK_DYLIB is analogous to LC_LOAD_DYLIB and doesn't require any special handling. Test plan: make check-all
Diff Detail
Unit Tests Event Timeline
Comment Actions I'm good with this, although I might suggest a different naming scheme with this and related tests, namely to start with "lc"/"load-command" or similar (perhaps lc-weak-dylib.test for this test). That way, all load command tests will appear adjacent to each other in the directory list, because they'll all have the same prefix, making it easier to find tests. Please also use '-' instead of '_' in test names, for consistency with existing tests, and for easier typing!
Comment Actions LG once the strange test file name *.test.test is fixed.
Comment Actions FWIW, the test name looks fine to me (i.e. doesn't have '.test.test'). For the record, my previous example was just to do with the dashes and "lc" prefix rather than suffix. The current name does indeed make more sense than my rough suggestion. |
The code looks good, but how is the test named? The actual command is named LC_LOAD_WEAK_DYLIB, and I did not expect that the name components are shuffled as weak load lc...
If the test makes more sense as an addition to basic-executable-copy.test, please do so, because we probably don't want to add a test for each such command. It seems to me that basic-executable-copy.test is a bit complicated now but I don't know whether splitting it is feasible.