Page MenuHomePhabricator

[mlir] Rename {lib,include/mlir}/Dialect/AffineOps to Affine
AbandonedPublic

Authored by ftynse on Mar 3 2020, 7:01 AM.

Details

Summary

BEGIN_PUBLIC
[mlir] Rename {lib,include/mlir}/Dialect/AffineOps to Affine

This makes dialect names more consistent. Since dialects are not only Ops, and
they are already scoped under Dialect/, there is little sense in suffixing them
with "Ops".
END_PUBLIC

Diff Detail

Event Timeline

ftynse created this revision.Mar 3 2020, 7:01 AM
bmahjour removed a subscriber: bmahjour.Mar 3 2020, 7:04 AM
nicolasvasilache accepted this revision.Mar 3 2020, 8:26 AM
This revision is now accepted and ready to land.Mar 3 2020, 8:26 AM
rriddle accepted this revision.Mar 3 2020, 9:22 AM
rriddle added inline comments.
mlir/include/mlir/Dialect/Affine/EDSC/Intrinsics.h
8

Can you please fix all of these header guards now that AFFINEOPS -> AFFINE?

ftynse abandoned this revision.Apr 3 2020, 6:32 AM