Use the same convention as all the other WebAssembly builtin names.
Details
Details
Diff Detail
Diff Detail
- Repository
- rL LLVM
Event Timeline
lib/CodeGen/CGBuiltin.cpp | ||
---|---|---|
12528 ↗ | (On Diff #171159) | But unlike others, isn't the input type different from the output type for this builtin? It seems other non-SIMD saturate_s intrinsics follow the same convention, trunc_saturate_s_output_input. |
lib/CodeGen/CGBuiltin.cpp | ||
---|---|---|
12528 ↗ | (On Diff #171159) | Ok, I can put the return type back in. My rationale for removing it was that for the SIMD truncations, the return type is uniquely determined by the input type, so specifying both in the name is redundant. |
lib/CodeGen/CGBuiltin.cpp | ||
---|---|---|
12528 ↗ | (On Diff #171159) | I see, but I still think it's easier to readers if they specify return types, in that they don't have to look up SIMD specs when using builtins. |