Archives created with ThinLTO are bitcodes, they also need to be searched for excluded symbols.
Details
Diff Detail
- Repository
- rL LLVM
Event Timeline
Test case?
ELF/Driver.cpp | ||
---|---|---|
1164–1168 ↗ | (On Diff #153824) | Move this code into a lambda and call it from both places. |
ELF/Driver.cpp | ||
---|---|---|
1156 ↗ | (On Diff #153841) | We don't need to give a long descriptive name for a local variable whose scope is narrow. Also, in LLVM/lld, local variables must be in CamelCase. I'd name this just Visit. |
ELF/Driver.cpp | ||
---|---|---|
1156 ↗ | (On Diff #153841) |
Given that this is a function-like object, I'd argue for lowerCamelCase here. |
Is that part of our coding standard? In lld, all local variables holding
function-like objects are in CamelCase, not in camelCase.
Last I checked the coding standard did not call out local variables that are function-like specifically. I've seen them both ways in LLVM, and I prefer aligning them with other functions than with local variables.
If lld is entirely consistent don't let me get in the way.
It may make sense to get a consensus and update the coding standard
document, as it is not entirely clear. If that's the case, I'd vote for
CamelCase. :)
Way ahead of you :)
http://lists.llvm.org/pipermail/llvm-dev/2018-July/124466.html
https://reviews.llvm.org/D48991
(But let's not hold up this review on that bike-shed...)