This commit adds a wrapper for std::distance() which works with ranges.
As it would be a common case to write distance(predecessors(BB)), this
also introduces pred_size() and succ_size() helpers to make that
easier to write.
Details
Diff Detail
Event Timeline
One motivation for this might be that meaning of distance(predecessors(b)) isn't obvious at first glance. Is that your concern?
If so, maybe it would be even simpler to name the new helper size. This would be more general than introducing pred_size/succ_size/etc, and might be easier to read overall. Wdyt?
I think if its equivalent to range-based version of std::distance its name should be llvm::distance.
My comment was just an observation that a majority of the uses were for predecessors/successors and maybe we should just make that easier. We already have pred_empty and succ_empty. pred_size and succ_size don't seem like much of a stretch.
Nice, I was looking for something like this when updating MergedLoadStoreMotion.cpp.
LGTM! (assuming that @craig.topper is happy with the last update)
I feel like a range-based version of std::distance isn't so much distance
anymore, by virtue of it being over a range & is actually probably more
suitably named 'size'. (in the case of std::distance, the name is really
talking about the two elements separately "what's the distance from this
iterator to this other iterator" not talking about a range defined by those
two iterators - so the name make sense there in a way that I don't think it
makes sense for ranges ("what is the distance of a range?" isn't a
cromulant question, I think... ))
I'd vote for llvm::size (& I think the general idea/concept/thing is a good
thing to add).
Though I guess one issue with size/distance is: how expensive is this? I'd
sort of be inclined only to provide this for ranges over random access
iterators (so it's only O(1), never O(N)), maybe? Let the more obscure
cases use std::distance(begin, end) to hopefully clarify that they're
weird/interesting/maybe expensive.
Should this just be V->getNumUses()?