Currently, indentation of Objective-C method names which are wrapped
onto the next line due to a long return type is controlled by the
style option IndentWrappedFunctionNames.
This diff changes the behavior so we always indent wrapped Objective-C
selector names.
Test Plan: Tests updated. Ran tests with:
% make -j12 FormatTests && ./tools/clang/unittests/Format/FormatTests
Do we explicitly want these to be generic with the intent to later reuse the enum for C++ method wrapping style?