r314974 introduced insertion of DEBUG_VALUEs after
each redefinition of debug value register in the slot index range.
In case the instruction redefining the debug value register
was a terminator, machine verifier would complain since it
enforces the rule of no non-terminator instructions
following the first terminator.
The change makes perfect sense. From a readability point of view, I'd perhaps prefer to express this concept in the while condition, or else have a separate if statement for it, i.e. either
while (I != MBB->end() && !I->isTerminator())
or
while (I != MBB->end()) {