Rename some interface methods to be consistent with the new accessor names.
This is a preparation for adding a ReduceOp, which then will implement
getIteratorTypes() and getOutputs() instead of iterator_types() and outputs().
Details
Details
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
Comment Actions
@nicolasvasilache I have extracted this change from https://reviews.llvm.org/D134731 as it is a potentially breaking change for downstream users.
Seems safer to have that in a separate patch.
More cleanup for this interface needs to be done in the future, but @pifon2a is already working on it, so I would prefer to keep this change limited to what we need for ReduceOp.