Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
mlir/lib/Dialect/Arithmetic/Transforms/EmulateWideInt.cpp | ||
---|---|---|
84 | As commented in the previous patch, I think it's more natural to put these two halves adjacent. (Eventually we'd need to support memory types and load/store ops; putting them adjacent would also mean easier to handle there and better load/store behavior.) Any reason transposing it like this way? | |
96 | Just make this as a static helper function? | |
mlir/test/Dialect/Arithmetic/emulate-wide-int.mlir | ||
68 | Can use {LITERAL} to avoid all the escapes. https://llvm.org/docs/CommandGuide/FileCheck.html#directive-modifiers |
mlir/lib/Dialect/Arithmetic/Transforms/EmulateWideInt.cpp | ||
---|---|---|
39 | Please add a short doc |
mlir/lib/Dialect/Arithmetic/Transforms/EmulateWideInt.cpp | ||
---|---|---|
39 | Can you add code headers? //===---------------------------------------------===// // ConvertConstant //===---------------------------------------------===// |
Added headers. Rebased.
mlir/lib/Dialect/Arithmetic/Transforms/EmulateWideInt.cpp | ||
---|---|---|
95 | Done. Are these headers standardized / covered by the coding convention in this part of MLIR, or more of a personal preference? |
mlir/lib/Dialect/Arithmetic/Transforms/EmulateWideInt.cpp | ||
---|---|---|
95 | They're nice to have when files start getting really long and op/pattern/pass definitions start to blur together. They also clearly indicate where new code should go that belong to the category (e.g. helper functions for patterns, etc.) |
Please add a short doc