Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
The new test fails in the pre merge checks.
Maybe the diff is missing some more changes?
clang-tools-extra/clangd/AST.cpp | ||
---|---|---|
793–794 | NIT: maybe rename to PackLocation? | |
828 | NIT: doesn't this work without dyn_cast? looks redundant, I expect derived-to-base conversion to do the right thing. | |
871–874 | Could you update the comment to account for the new semantics? | |
clang-tools-extra/clangd/unittests/InlayHintTests.cpp | ||
1446 ↗ | (On Diff #446457) | NIT: maybe test for the case with a single expansion here: foo(Foo(args...), 1); foo({args...}, 1); ? testing multiple expansions is also interesting, but seems orthogonal to the change being made here. |
NIT: maybe rename to PackLocation?
now that there is only 1 variable we could use a shorter name without any confusion