Page MenuHomePhabricator

[AMDGPU][LLD] Adding support for ABI version 5 option
ClosedPublic

Authored by lamb-j on Mar 21 2022, 2:57 PM.

Details

Summary

Code object version 5 will use the same EFlags as version 4, so we only need to add an additional case

Diff Detail

Event Timeline

lamb-j created this revision.Mar 21 2022, 2:57 PM
Herald added a project: Restricted Project. · View Herald Transcript
lamb-j requested review of this revision.Mar 21 2022, 2:57 PM
Herald added a project: Restricted Project. · View Herald TranscriptMar 21 2022, 2:57 PM
lamb-j updated this revision to Diff 417110.Mar 21 2022, 2:58 PM

Updating commit message

This change goes along with 1194b9cdda30d and should probably have been landed with it.

Do we need to add the test for it?

lamb-j updated this revision to Diff 417395.Mar 22 2022, 1:56 PM

Adding test

MaskRay requested changes to this revision.Mar 22 2022, 2:00 PM

Can the test be placed in the existing amdgpu-tid.s
The difference with ELFABIVERSION_AMDGPU_HSA_V4 is so small that I don't think we need so many extra RUN lines.

This revision now requires changes to proceed.Mar 22 2022, 2:00 PM
lamb-j updated this revision to Diff 417437.Mar 22 2022, 4:50 PM

Switching test

MaskRay accepted this revision.Mar 22 2022, 5:11 PM

LGTM.

This revision is now accepted and ready to land.Mar 22 2022, 5:11 PM
This revision was automatically updated to reflect the committed changes.