Switched to using new custom operands design.
See https://reviews.llvm.org/D121696.
Details
Diff Detail
Unit Tests
Time | Test | |
---|---|---|
60,130 ms | x64 debian > BOLT.runtime/X86::exceptions-pic.test | |
60,250 ms | x64 debian > LLVM.CodeGen/NVPTX::wmma.py | |
60,230 ms | x64 debian > LLVM.MC/Mips::mips-jump-pc-region.s |
Event Timeline
llvm/lib/Target/AMDGPU/Utils/AMDGPUAsmUtils.cpp | ||
---|---|---|
24 | I think it would be neater to define and use a new isGFX8GFX9 instead of having a lambda inside this table. (And the same for the hwreg table that you pushed already.) |
LGTM (with or without addressing my nitpicks about naming).
llvm/lib/Target/AMDGPU/Utils/AMDGPUBaseInfo.cpp | ||
---|---|---|
1500 | Maybe it would be simpler to implement this as "isNotGFX10Plus" instead? | |
1522 | In AMDGPU.td there is a predicate called "isGFX10Before1030". Maybe we should use the same name in both places? I don't have a preference for which name is better. |
clang-format: please reformat the code
22 diff lines are omitted. See full path.