This is an archive of the discontinued LLVM Phabricator instance.

[mlir][OpDSL] Rename function to make signedness explicit (NFC).
ClosedPublic

Authored by gysit on Feb 25 2022, 5:49 AM.

Details

Summary

The revision renames the following OpDSL functions:

TypeFn.cast -> TypeFn.cast_signed
BinaryFn.min -> BinaryFn.min_signed
BinaryFn.max -> BinaryFn.max_signed

The corresponding enum values on the C++ side are renamed accordingly:

#linalg.type_fn<cast> -> #linalg.type_fn<cast_signed>
#linalg.binary_fn<min> -> #linalg.binary_fn<min_signed>
#linalg.binary_fn<max> -> #linalg.binary_fn<max_signed>

Depends On D120110

Diff Detail

Event Timeline

gysit created this revision.Feb 25 2022, 5:49 AM
gysit requested review of this revision.Feb 25 2022, 5:49 AM

@aartbik I actually the longer names are better in this case!

aartbik accepted this revision.Feb 25 2022, 1:34 PM
This revision is now accepted and ready to land.Feb 25 2022, 1:34 PM
gysit updated this revision to Diff 411991.Mar 1 2022, 12:06 AM

Rebase.

This revision was landed with ongoing or failed builds.Mar 1 2022, 12:19 AM
This revision was automatically updated to reflect the committed changes.