Instead of trying to squeeze GetVersion into lldb-private.h, give it its own header and implementation file in its own directory. I called it Basic, partially because the library was already called lldbBase (?) but mostly to align with clang/Basic/Version.h (and swift/Basic/Version.h) which might explain the current library name. I'm pretty flexible as far as naming goes, I think Version/Version.h would work pretty well too.
Additional benefits of this patch include that we can get rid of the quoting macros and that other place of LLDB can read the version number from Version.inc. A downstream change requiring the latter was the main motivation for this patch. I considered adding a few other functions similar to what clang offers but decided against it since there would be no existing uses for them.
should lldb.cpp be deleted too?