Page MenuHomePhabricator

[Clang][Codegen] rename no_profile fn attr no_profile_instrument_function
ClosedPublic

Authored by nickdesaulniers on Jun 21 2021, 11:03 AM.

Details

Summary

GCC has had this function attribute since GCC 7.1 for this purpose. I
add "no_profile" last week in D104475; rename this to
"no_profile_instrument_function" to improve compatibility with GCC.

Link: https://gcc.gnu.org/bugzilla/show_bug.cgi?id=80223#c11

Diff Detail

Event Timeline

nickdesaulniers requested review of this revision.Jun 21 2021, 11:03 AM
nickdesaulniers created this revision.
Herald added a project: Restricted Project. · View Herald TranscriptJun 21 2021, 11:03 AM
Herald added a subscriber: cfe-commits. · View Herald Transcript
This revision is now accepted and ready to land.Jun 21 2021, 11:13 AM
MaskRay accepted this revision.Jun 21 2021, 11:20 AM

(This was why I suggested we waited a bit on GCC's response...)

This revision was landed with ongoing or failed builds.Jun 21 2021, 11:42 AM
This revision was automatically updated to reflect the committed changes.