- Group Reviewers
- rG2021d272ad6c: [libc++] Implement ranges::view
What if you named these more like the types in the other test file? So this would be Empty, next would be PrivateViewBase, then EnableViewFalse, then DerivesViewBase, then EnableViewTrue (or something similar).
Would definitely take a paper and implementation experience.
So the original reason to indent it that way was to make the thing we're actually trying to test stand out. But I guess I'll remove it :-).
LGTM overall, tests are very elegant! Would you mind adding checks that our existing ranges aren't views to the conformance tests please?