Accompanying patch for D84602: [MSP430] Expose msp430_builtin calling convention to C code that gives a meaningful name for msp430_builtin calling convention in .ll sources (msp430_builtincc instead of cc94).
A shy ping :)
On one hand, this patch is rather useless without D84602: [MSP430] Expose msp430_builtin calling convention to C code and scary D84636: [RFC] Make the default LibCall implementations from compiler-rt builtins library more customizable. On the other hand, this one is expected to merely rename a cc94 attribute to meaningful msp430_builtincc. The only possible drawback I see is that someone may want to give it more descriptive name, as only a small subset of "builtin" functions (LibCall, in fact) use it while most of them just have a default CC. In this patch, it is named after the pre-existed CallingConv::MSP430_BUILTIN.
Another note is that it is not expected to be used by someone except for compiler-rt developers. Frankly speaking, this patch does not block anything at all, it just adds some neater name to an entity that is expected to be used by means of __attribute__. So, compiler-rt developers will probably only need it while reading the listings for debug purposes, as well. :)