Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Unit Tests
Event Timeline
Unit tests: pass. 62280 tests passed, 0 failed and 827 were skipped.
clang-tidy: pass.
clang-format: pass.
Build artifacts: diff.json, clang-tidy.txt, clang-format.patch, CMakeCache.txt, console-log.txt, test-results.xml
Pre-merge checks is in beta. Report issue. Please join beta or enable it for your project.
Unit tests: fail. 62306 tests passed, 1 failed and 838 were skipped.
failed: libc++.std/thread/thread_mutex/thread_mutex_requirements/thread_timedmutex_requirements/thread_timedmutex_recursive/try_lock_until.pass.cpp
clang-tidy: pass.
clang-format: pass.
Build artifacts: diff.json, clang-tidy.txt, clang-format.patch, CMakeCache.txt, console-log.txt, test-results.xml
Pre-merge checks is in beta. Report issue. Please join beta or enable it for your project.
Great cleanup. The call sites look great. Thanks for doing this!
mlir/include/mlir/Dialect/VectorOps/VectorUtils.h | ||
---|---|---|
31 | I think this could be named "computeStrides" as it could be applied to non-slices as well. It just takes a 'shape' and 'sizes'. | |
40 | Since this is a library it might be good to make the name more verbose: computeElementOffsetsFromVectorSliceOffsets | |
40 | Given the target slice sizes of a vector... | |
47 | nit: I prefer "computeSliceSizes", but good either way. |
Thanks! I was not sure on the naming, and like your suggestions better indeed. All addressed.
mlir/include/mlir/Dialect/VectorOps/VectorUtils.h | ||
---|---|---|
1 | Utils.h -> VectorUtils.h? | |
37 | All these utilities returning SmallVector should be turned into void utility_name(..., SmallVectorImpl<element_type>& output_name) so that they can accept SmallVectors of arbitrary static sizes. | |
mlir/lib/Dialect/VectorOps/VectorTransforms.cpp | ||
115 | just curious... why is this static_cast needed? |
mlir/include/mlir/Dialect/VectorOps/VectorUtils.h | ||
---|---|---|
37 | Note that this is a refactoring of existing code, so I would prefer to do that as follow up. But just in case you insist, can you point me to at least one occurrence of this elsewhere in the tree? | |
mlir/lib/Dialect/VectorOps/VectorTransforms.cpp | ||
115 | size_t vs int64_t (may cause some compilers to complain about sign diff in comparison) |
Unit tests: pass. 62309 tests passed, 0 failed and 838 were skipped.
clang-tidy: pass.
clang-format: pass.
Build artifacts: diff.json, clang-tidy.txt, clang-format.patch, CMakeCache.txt, console-log.txt, test-results.xml
Pre-merge checks is in beta. Report issue. Please join beta or enable it for your project.
mlir/include/mlir/Dialect/VectorOps/VectorUtils.h | ||
---|---|---|
37 | Agree, we can address this separately. | |
mlir/lib/Dialect/VectorOps/VectorTransforms.cpp | ||
115 | Thanks! Sorry, I thought the cast applied to the result of the comparison. My bad. |
mlir/include/mlir/Dialect/VectorOps/VectorUtils.h | ||
---|---|---|
37 | Ah, I see what you mean. Thanks for pointing this out. |
Unit tests: pass. 62310 tests passed, 0 failed and 838 were skipped.
clang-tidy: pass.
clang-format: pass.
Build artifacts: diff.json, clang-tidy.txt, clang-format.patch, CMakeCache.txt, console-log.txt, test-results.xml
Pre-merge checks is in beta. Report issue. Please join beta or enable it for your project.
Utils.h -> VectorUtils.h?