Remove unnecessary "OptModule" section. Add "PerFunctionPasses", "PerModulePasses" and "CodeGenPasses" sections under "Backend" section.
I like this.
One more related question - there are two "Frontend" sections, second one appears to consist only of "CodeGen Function"s.
Is that correct? Should they both be in an actual front-end section, and should they be renamed to, i dunno,
"Sema" and "Codegen"? I'm not sure about this, just raising a question.