Page MenuHomePhabricator

[NFC][TSan] Move libdispatch tests into their own subfolder

Authored by yln on Mar 13 2019, 5:02 PM.



Remove 'gcd' file prefix. GCD stands for Grand Central Dispatch, which
is another name for libdispatch.

Remove REQUIRE: dispatch from tests.

Also rename lit feature 'dispatch' -> 'libdispatch' to be more explicit
what this is about.

Diff Detail


Event Timeline

yln created this revision.Mar 13 2019, 5:02 PM
Herald added projects: Restricted Project, Restricted Project. · View Herald TranscriptMar 13 2019, 5:02 PM
Herald added subscribers: llvm-commits, Restricted Project, jdoerfert, kubamracek. · View Herald Transcript
kubamracek accepted this revision.Mar 14 2019, 1:13 PM

Looks good, but I assume this needs the other patches to land first, right?

This revision is now accepted and ready to land.Mar 14 2019, 1:13 PM
This revision was automatically updated to reflect the committed changes.