This patch extends CFGSort pass to support exception handling. Once it
places a loop header, it does not place blocks that are not dominated by
the loop header until all the loop blocks are sorted. This patch extends
the same algorithm to exception 'catch' part, using the information
calculated by WebAssemblyExceptionInfo class.
Details
Diff Detail
- Repository
- rL LLVM
- Build Status
Buildable 20085 Build 20085: arc lint + arc unit
Event Timeline
- Use unique_ptr for containers and delete destructors
- Make wasm.get.exception/ehselector intrinsic take a token argument
This change is really quite nice and minimal other than the renaming.
lib/Target/WebAssembly/WebAssemblyCFGSort.cpp | ||
---|---|---|
41 | 'SortUnit' to me implies that this is a thing that is being sorted, i.e. compared against other units, which isn't correct. What about if we called this a 'Region'? | |
199 | Even when comparing backwards? I don't quite understand why this shouldn't just be the inverse of forward comparison. |
lib/Target/WebAssembly/WebAssemblyCFGSort.cpp | ||
---|---|---|
199 | For some reason I don't fully understand, for Ready list later BBs are selected first. But my intention here is no matter whether the list is Preferred (which uses CompareBlockNumbers) or Ready (which uses CompareBlockNumbersBackwards), whenever we have an EH pad ready, we want to pick it first. So CompareBlockNumbersBackwards doesn't mean its results will be used in the reverse direction. Regardless of the comparison function, a BB indicated by the function as having higher priority is placed before when sorting. |
lib/Target/WebAssembly/WebAssemblyCFGSort.cpp | ||
---|---|---|
85 | We could also assert that ML and WE aren't both set. | |
199 | OK. This whole bit with the comparison functions still seems a little awkward to me though. At the very least there should be a comment here saying something about the usage or why it's not just the inverse of the above (especially since the name seems to imply that it is). Or maybe it just needs a better name? Perhaps @sunfish knows why the queues sort in the opposite directions. Or, stepping back, more, would it make more sense to just have separate queue (alongside Preferred and Ready) for EH pads? Preferred and Ready are basically 2 different priority classes, and we are now adding a third, but we are handling its prioritization differently from the other 2. |
lib/Target/WebAssembly/WebAssemblyCFGSort.cpp | ||
---|---|---|
14–16 | This "and" should be "or". | |
70 | Could you add a comment for this class that briefly describes its purpose? Do I understand correctly that this is essentially the SortUnit analog of what LoopInfo is for loops? | |
199 | It was an early attempt at balancing two concerns: preserving the original code layout to the extent possible, while also keeping contiguous sequences contiguous. It worked on some simple testcases. It's probably not optimal. |
lib/Target/WebAssembly/WebAssemblyCFGSort.cpp | ||
---|---|---|
70 | Yes that's what it is. And I renamed them to Region and RegionInfo per @dschuff's suggestion. | |
85 | They can be both set. In that case we return the smaller one. | |
199 | @dschuff Let me clarify a bit. You can think of those two queue as just queue Alpha and queue Beta or something. Here they happen to be CompareBlockNumbersForward and CompareBlockNumbersBackward and they sound like they have some opposite relationship and thus confusing, but they are just different ways to pick a block. What I want is, I want to impose a universal rule of "pick an EH pad first whenever it is available" for all queues available. So why the queues sort in the opposite direction doesn't really matter. And also having a separate queue for EH pads wouldn't do what I want (I want impose a universal rule for all queues, as I said). If we make this as a separate queue, it is unclear how we should modify the logic itself to figure out when we should switch to this specific queue. For comment-wise, I'm not sure what I should add more to what's already there. Should I add what I described here? |
LGTM With those changes.
lib/Target/WebAssembly/WebAssemblyCFGSort.cpp | ||
---|---|---|
199 | Maybe the long comment about EH pad handling could go outside both comparators, and it could note that EH pads are selected first regardless of the block comparison order. I also actually think that changing the name to CompareBlockNumbersAndEHPad doesn't really make them more understandable, and I'd probably just leave the names the same (while keeping the comments). | |
250 | Could also add one note here like 'EH blocks are picked first from both queues.' |
This "and" should be "or".