Move UseDwarfRangesBaseAddressSpecifier handling to the MC options command line argument.
This is a change to make the flag more accessible without needing to pass in arguments directly to the
Following this change, what would be a better name for this flag given that the
current name is rather verbose? Are there any opinions around this?