Details
Diff Detail
- Repository
- rLLD LLVM Linker
- Build Status
Buildable 12876 Build 12876: arc lint + arc unit
Event Timeline
Patch LGTM, please wait for Rui approval.
ELF/Target.h | ||
---|---|---|
150 | nit: I would shorten this: |
ELF/Target.h | ||
---|---|---|
150 | Sounds good, I'll change if it to that if Rui also agrees. |
ELF/Target.h | ||
---|---|---|
173 | Since we only call this with values <= INT64_MAX that is much better, thanks. |
ELF/Target.h | ||
---|---|---|
173 | But why INT64_MAX? It seems just inconsistent. If you sign-extend, you want to always do that, no? |
ELF/Target.h | ||
---|---|---|
173 | I meant that this function is either called with a negative signed number or an unsigned value that doesn't have the int64 sign bit set so that using Twine((int64_t)V) is exactly the same as the ternary expression that I had here. |
ELF/Target.h | ||
---|---|---|
173 | If Twine((int64_t)V) is exactly the same as the ternary expression, please use the simpler form which is Twine((int64_t)V). |
ELF/Target.h | ||
---|---|---|
173 | Yes that is exactly what I meant. Sorry about the miscommunication. |
In general a function name should be a verb, so how about reportRangeError?