We've had embedded developers requesting we extend the ARM_VFPVn series to support Cortex-M7, which sounds reasonable apart from the name bikeshedding.
The features added are equivalent to a v8 FPU and the LLVM codebase is pretty split on whether it's fp-armv8 or vfpv5. Since this is user-facing, I thought I'd ask for opinions. The obvious choices are:
- __ARM_VFPV5__ everywhere (including Cortex-A57 for example). This matches Cortex-M7 naming from ARM, but probably not Cortex-A57. It also matches our historical #defines.
- __ARM_FPV8__ (or similar) everywhere. Reverse problem from above.
- Both, depending on whether the CPU really is v8. No naming mismatch, but two #defines for what's essentially the same thing. It's difficult to imagine code actually wanting to distinguish the two.
I've got a mild preference for the first, hence this patch. Any objections or other suggestions?
Tim.