Instead, inline them into the getStableStorageLocation() overloads, which is the only place they were called from (and should be called from).
getStorageLocation() / setStorageLocation() were confusing because neither their name nor their documentation made reference to the fact that the storage location is stable.
It didn't make sense to keep these as private member functions either. The code for the two getStableStorageLocation() overloads has become only marginally more complex by inlining these functions, and the Expr version is actually more efficient because we only call ignoreCFGOmittedNodes() once instead of twice.