Add functions AMDGPU::DepCtr::encodeField*() and AMDGPU::DepCtr::decodeField*()
for each of vm_vsrc, va_vdst and sa_sdst. These are now used in
AMDGPUInsertDelayAlu and GCNHazardRecognizer so as to make working with
S_WAITCNT_DEPCTR operands easier and more readable.
Details
Details
Diff Detail
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
llvm/lib/Target/AMDGPU/GCNHazardRecognizer.cpp | ||
---|---|---|
1297 | This is wrong. it should be a simple test that sa_sdst is zero, not a test that everything that isn't sa_sdst is set while sa_sdst isn't cared about. Fixing this requires a lit test to be updated, however, so I'll make that a separate patch. |
Comment Actions
LGTM.
llvm/lib/Target/AMDGPU/GCNHazardRecognizer.cpp | ||
---|---|---|
1173 | Strictly speaking changes like this one are not NFC, since the new code ignores the non-VmVsrc bits of the immediate value, but that seems like an obvious improvement. |
Strictly speaking changes like this one are not NFC, since the new code ignores the non-VmVsrc bits of the immediate value, but that seems like an obvious improvement.