Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
mlir/lib/Dialect/SparseTensor/Transforms/SparseBufferRewriting.cpp | ||
---|---|---|
1037 | isn't the nTrailingP a boolean here, deciding between two versions? You even start with assert(nTrailingP == 1 || nTrailingP == 0); bool isHybrid = (nTrailingP == 1); so why not just passing in isHybrid? |
mlir/lib/Dialect/SparseTensor/Transforms/SparseBufferRewriting.cpp | ||
---|---|---|
48 | Why not name this "_sparse_qsort_" so that it matches the "_sparse_hybrid_qsort_" name? |
mlir/lib/Dialect/SparseTensor/Transforms/SparseBufferRewriting.cpp | ||
---|---|---|
1037 | This is because FuncGeneratorType requires it to be an uint32_t. And the reason that FuncGeneratorType uses uint32_t not boolean is we can potentially have more trailing data, such as for collecting the number of swaps performed. |
Why not name this "_sparse_qsort_" so that it matches the "_sparse_hybrid_qsort_" name?