The intention is to have this op lowered to
llvm.intr.uadd.with.overflow or spv.IAddCarry. LLVM has a second
intrinsic for signed add-with-overflow, llvm.intr.sadd.with.overflow,
with different semantics. Therefore we should have 2 ops with arith,
and be explicit about signed/unsigned semantics.
Rename arith.addi_carry to arith.addui_carry before we introduce a
signed version of this op: arith.addsi_carry.