Mostly mechanical, avoiding function name conflicts.
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
mlir/include/mlir/Dialect/Vector/IR/VectorOps.td | ||
---|---|---|
72–74 | getAsValueRange? |
mlir/include/mlir/Dialect/Vector/IR/VectorOps.td | ||
---|---|---|
72–74 | Here the storage is an array of Attribute type, so I'd have to getAsValueRange<Attribute, AffineMapAttr> and then map over that to get the AffineMap out before then constructing vector of AffineMap. That decreases the readability for me. |
mlir/include/mlir/Dialect/Vector/IR/VectorOps.td | ||
---|---|---|
72–74 | Is $_self here not an ArrayAttr? If it is, $_self.getAsValueRange<AffineMapAttr>() should do the exact same thing as this map_range. |
mlir/include/mlir/Dialect/Vector/IR/VectorOps.td | ||
---|---|---|
72–74 | That would be true if this were returning a vector of AffineMapAttr. Here it is a vector of AffineMap, so there needs to be another mapping over the range to getValue on AffineMapAttr. |
mlir/include/mlir/Dialect/Vector/IR/VectorOps.td | ||
---|---|---|
72–74 | Seems I was making a typo there the whole time (tried a few combos and all failed, then just retried and it worked) |
getAsValueRange?