Page MenuHomePhabricator

[NFC][loop-idiom] Rename Stores to IgnoredInsts; Fix a typo

Authored by zhuhan0 on Aug 18 2021, 12:09 AM.



When dealing with memmove, we also add the load instruction to the ignored
instructions list passed to mayLoopAccessLocation. Renaming "Stores" to
"IgnoredInsts" to be more precise.

Diff Detail

Event Timeline

zhuhan0 created this revision.Aug 18 2021, 12:09 AM
zhuhan0 requested review of this revision.Aug 18 2021, 12:09 AM
Herald added a project: Restricted Project. · View Herald TranscriptAug 18 2021, 12:09 AM
yurai007 added inline comments.Aug 18 2021, 6:02 AM

Out of the scope but maybe it's good opportunity to change it to something like "new call has been formed"?

hoy accepted this revision.Aug 18 2021, 9:21 AM


This revision is now accepted and ready to land.Aug 18 2021, 9:21 AM
zhuhan0 updated this revision to Diff 367250.Aug 18 2021, 10:41 AM

Address comment.

zhuhan0 marked an inline comment as done.Aug 18 2021, 10:42 AM
This revision was landed with ongoing or failed builds.Aug 18 2021, 10:54 AM
This revision was automatically updated to reflect the committed changes.