Context-sensitive AutoFDO profile has a different name scheme where full calling contexts are encoded as function names. When processing CS proifle, llvm-profdata should use full contexts instead of leaf function names.
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
llvm/tools/llvm-profdata/llvm-profdata.cpp | ||
---|---|---|
701 | I see explicit hasValue() call used all over the place for Optional values, and I also feel it's more readable to spell it out instead of relying on operator(). Not sure if it's an established convention though. |
llvm/tools/llvm-profdata/llvm-profdata.cpp | ||
---|---|---|
701 | Not sure about the convention. There are also usages like this (using operator()) in LLVM. But agreed it's more clear with hasValue(). Will change to that. |
llvm/tools/llvm-profdata/llvm-profdata.cpp | ||
---|---|---|
1907–1910 | This is not added for cs instrument fdo profile. Could you update the the description to differentiate with csspgo? | |
1917–1920 | Is it better to update the description for csspgo since the function filter will be used as context filter? similar for value-cutoff and similarity-cutoff. |
I see explicit hasValue() call used all over the place for Optional values, and I also feel it's more readable to spell it out instead of relying on operator(). Not sure if it's an established convention though.