This patch adds the default value of 1 to drop_begin.
In the llvm codebase, 70% of calls to drop_begin have 1 as the second
argument. The interface similar to with std::next should improve
readability.
This patch converts a couple of calls to drop_begin as examples.
clang-tidy: warning: invalid case style for function 'drop_begin' [readability-identifier-naming]
not useful