Right now slicing would assert if an operation with multiple results is in the slice.
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
mlir/lib/Analysis/SliceAnalysis.cpp | ||
---|---|---|
57 | Nit: this shouldn't really be named ownerOp but a userOp. It's an owner op just for the OpOperand which isn't really in the picture. | |
173–174 | Missing space - clang-format please. | |
174 | Nit: Please avoid auto or use a better name (agree that this existed before). auto -> OpOperand or u -> opOperand. | |
174 | You could just do an r.getUsers(). You only need the user ops. |
mlir/lib/Analysis/SliceAnalysis.cpp | ||
---|---|---|
57 | I'm not really changing this part of the code and the same naming is used several times so I would rather keep it consistent and send a NFC patch to change all the uses if you think it should be changed. |
mlir/lib/Analysis/SliceAnalysis.cpp | ||
---|---|---|
57 | If you are already touching a line, an NFC change to that same line (for example something like naming that improves readability) is completely fine to go along. We don't need a separate NFC patch (unless there are additional surrounding lines of code being modified). |
mlir/lib/Analysis/SliceAnalysis.cpp | ||
---|---|---|
174 | The comment about auto haven't been addressed: in general please spell the type when using auto does not improve readability (Value -> auto does not seem better to me, just like Operation * -> auto *) |
mlir/lib/Analysis/SliceAnalysis.cpp | ||
---|---|---|
174 | Replace auto. |
Nit: this shouldn't really be named ownerOp but a userOp. It's an owner op just for the OpOperand which isn't really in the picture.