Currently this alias instantiates the readability-identifier-naming check, just swap it out to use the readability-named-paramater check.
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
I do not understand the justification here -- IdentifierNamingCheck and NamedParameterCheck are two different checks. How do you know that this swap continues to honor the HIC++ coding standard?
Because thats what the documentation says
In docs/checks/hicpp-named-paramater.rst:
hicpp-named-parameter This check is an alias for readability-named-parameter. Implements rule 8.2.1.
From https://www.perforce.com/resources/qac/high-integrity-cpp-coding-standard/definitions:
8.2.1 Make parameter names absent or identical in all declarations
Its fairly obvious this has been incorrect since its inception. Arguable readability-named-paramater doesn't quite cover the extent of the HIC++ coding standard, but it goes a lot further than the identifier-naming-check does.
EDIT: Down the line I may create a check that fully enforces rule 8.2.1, but for now this is a good small step
Oof! Good catch! Thanks for the explanation, I was missing that bit.
EDIT: Down the line I may create a check that fully enforces rule 8.2.1, but for now this is a good small step
Agreed. LGTM