The method is used where TypeSize is implicitly cast to integer for
being checked against 0.
Details
Diff Detail
- Repository
- rG LLVM Github Monorepo
Event Timeline
I removed an instance of the isNonZero method, as the patch relates
only to the isZero method. I'll create a separate patch for that.
LGTM, thanks!
While this patch is quite trivial, for other patches, you may want to add a few more reviewers.
llvm/include/llvm/Support/TypeSize.h | ||
---|---|---|
153 | nit: I mentioned this to Graham when he first proposed TypeSize, but having this variable named 'MinSize' is a bit odd when you compare with Zero, because in a sense, the minimum size of <anything> is always zero :) |
Sure, will do. Added @efriedma for visibility, I'll wait some time before submitting to give them the possibility to comment in case they want to.
Thanks,
Francesco
llvm/include/llvm/Support/TypeSize.h | ||
---|---|---|
153 | Agree. Shall we rename it to KnownSize, and consequently rename the get method to getKnownSize? Thanks for the review! |
llvm/include/llvm/Support/TypeSize.h | ||
---|---|---|
153 | Of course, in a separate patch! :) |
nit: I mentioned this to Graham when he first proposed TypeSize, but having this variable named 'MinSize' is a bit odd when you compare with Zero, because in a sense, the minimum size of <anything> is always zero :)