There is a number of places in llvm-dwp.cpp where a section identifier is translated into an index of an internal array of section contributions, and another place where the index is converted to an on-disk value. All these places use direct expressions like <id> - DW_SECT_INFO or <index> + DW_SECT_INFO, exploiting the fact that DW_SECT_INFO is the minimum valid value of that kind.
The patch adds distinct functions for that translation. The goal is to make the code more readable and to prepare it to support index sections of new versions, where the numeric scheme of section indexes is changed.
LLVM doesn't generally use top level const on local variables - drop the "const" here.