When we have to widen to a 64-bit register, we have to emit a SUBREG_TO_REG.
Add a general-purpose widening helper (widenIfNeeded), which emits the correct SUBREG_TO_REG instruction based off of a desired size and add a testcase.
Also remove some asserts which are technically incorrect in emitTestBit.
- p0 doesn't count as a scalar type, so we need to check !Ty.isVector() instead
- Whenever we have a s1, the Size/Bit checks are too conservative, so just remove them
Replace these asserts with less conservative ones where applicable.
I think this should be named something more specific, like widenGPRBankRegIfNeeded or similar, because it's not a generic widening.